wiki:Build/Ubuntu

Building Aegisub 3.0.1 on Ubuntu 12.04

First install dependencies with packages:

$ sudo apt-get install build-essential libasound2-dev libass-dev libffms2-dev libfftw3-dev libgl1-mesa-dev libglu1-mesa-dev libgtk2.0-dev libhunspell-dev liblua5.1-dev

Ubuntu currently only packages wxWidgets 2.8, while Aegisub requires 2.9.4. To build wxWidgets 2.9.4:

$ cd ~
$ wget http://sourceforge.net/projects/wxwindows/files/latest/wxWidgets-2.9.4.tar.bz2
$ tar xjf wxWidgets-2.9.4.tar.bz2
$ cd wxWidgets-2.9.4
$ ./configure --with-opengl && make && sudo make install
$ sudo ldconfig

Build Aegisub itself:

$ cd ~
$ wget http://ftp.aegisub.org/pub/releases/aegisub-3.0.1.tar.xz
$ tar xJf aegisub-3.0.1.tar.xz
$ cd aegisub-3.0.1/aegisub
$ ./configure && make && sudo make install

You should now be able to start Aegisub by typing aegisub-3.0.

Spell checker dictionaries

To use the system spellchecker dictionaries in Aegisub open the Preferences dialog, and on the Interface page change "Dictionaries path" to "/usr/share/hunspell" and then restart Aegisub.

Last modified 19 months ago Last modified on 10/08/12 17:47:06