#1625 closed defect (fixed)

Build error: wxgtk 2.9.5 and wxStandardPaths

Reported by: Alucryd Owned by:
Milestone: 3.1.0 Component: General
Version: 3.0.4 Keywords:
Cc: Platform: All
Sub Component:

Description

Trying to build aegisub 3.0.4 against wxgtk 2.9.5 leads to an error on src/utils.cpp, please find attached the relevant build log part, along with a proposed patch.

The patch allows aegisub to build without error, but the top menu is missing from the interface (File, Edit, Subtitle...), everything else seems to work fine with wxgtk 2.9.5. Should I create another ticket for this?

Attachments (2)

build.log (1.1 KB) - added by Alucryd 16 months ago.
build log
wxgtk2.9.5.patch (1.1 KB) - added by Alucryd 16 months ago.
patch

Download all attachments as: .zip

Change History (4)

Changed 16 months ago by Alucryd

build log

Changed 16 months ago by Alucryd

patch

comment:1 Changed 16 months ago by Alucryd

Forgot to mention, I'm on Arch Linux x86_64.

comment:2 Changed 15 months ago by Plorkyeran

  • Milestone set to 3.1.0
  • Resolution set to fixed
  • Status changed from new to closed

(In [0a2c0ab75e7e52bdec79cf3c97aace49607d3909]) wxStandardPaths is protected as of wxgtk 2.9.5

Closes #1625, #1626, #1627.

Note: See TracTickets for help on using tickets.