Opened 5 years ago

Closed 5 years ago

#1201 closed defect (fixed)

Please clarify license and copyright of some automation scripts

Reported by: riccetn Owned by: verm
Milestone: 2.1.9 Component: General
Version: 2.1.8 Keywords:
Cc: Platform: All
Sub Component:

Description

The following automation scripts have unclear copyright and/or licensing information:
automation/demo/perl-console.pl
automation/demo/k-replacer.rb
automation/include/Aegisub/*
automation/include/Aegisub.pm
automation/include/utils.rb
automation/autoload/macro-*

I would appreciate if you could add copyright and licensing notices to the files.

Change History (7)

comment:1 Changed 5 years ago by TheFluff

  • Status changed from new to assigned

All of those except automation/autoload/macro-* are deprecated and not useable in any current version of Aegisub. They should be removed.

also: lol you care about copyrights on trivial 20-line scripts

comment:2 Changed 5 years ago by verm

  • Resolution set to invalid
  • Status changed from assigned to closed

Please see the LICENSE file, notably:

Any file that does not have a license in the header is covered by the above
license with exception to any directories that contain a license file, or are
covered by another license in the file itself.

If this is still an issue re-open the ticket and please explain what policies are in conflict.

comment:3 Changed 5 years ago by nielsm

For the Lua sample macros, the intention has been public domain or the closest legal equivalent.

comment:4 Changed 5 years ago by riccetn

I'm trying to package Aegisub for Ubuntu, so the relevant policies would be the parts of the Debian policy manual which deals with copyright namely:
http://www.debian.org/doc/debian-policy/ch-archive.html#s-pkgcopyright
http://www.debian.org/doc/debian-policy/ch-docs.html#s-copyrightfile

The tarballs of Aegisub 2.1.8 is missing the LICENSE file, but I see you have added it to the 2.1.9 branch. I think the notice in the LICENSE file is enough to cover this, but I'll report back if I get future problems.

comment:5 Changed 5 years ago by verm

  • Milestone set to 2.1.9
  • Resolution invalid deleted
  • Status changed from closed to reopened

Wait, the LICENSE file isn't in the tarball?!

Argh, I didn't even notice.. and noone has complained. The license is in svn the problem is I forgot to add it to DISTFILES. I clearly remember now thinking that automake would add it automatically, aparrantly I was wrong and I have no idea why I didn't check. oh well.

comment:6 Changed 5 years ago by verm

  • Owner set to verm
  • Status changed from reopened to accepted

comment:7 Changed 5 years ago by verm

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [d39b29c]) Merge r4261: Add LICENCE to distfiles closes #1201.

Note: See TracTickets for help on using tickets.