Opened 4 years ago

Closed 4 years ago

#1174 closed defect (worksforme)

karaoke lines invisible since 2.1.2

Reported by: anime-neechan Owned by:
Milestone: Component: Video
Version: 2.1.8 Keywords:
Cc: Platform: Windows
Sub Component:

Description

I've used for some time the 2.1.2 version, and have updated to 2.1.8. the problem is, some of my karaoke-files don't display in the video-window of aegisub. Even the basic "template line" example from your manual page: {\r\t($start,$mid,\fscy120)\t($mid,$end,\fscy100)}
aegisub creates the fx-lines, the variables are replaced correctly, but in the video-window, the effects aren't displayed. I even enabled the "drag subtitles" mode, in case my line was 'out of the window bounds', but the placement cursor is right where it should be.
the strange thing is, at some of my "template syl" karaokes, some of the syllables are shown, and some not. the lines look like swiss cheese.
I've deinstalled and re-installed all you older builds, but the last version which shows everything is 2.1.2. And i'm not the only one. I have a german tutorial, and there where a couple of same complaints.
I even updated my avisynth in case it wasn't up to date, but no effect. I use VirtualDubMod and the textsub 2.23 filter to 'burn' the subtitles into my video, and even if the subs aren't visible within aegisub, the resulting VDM-Video shows everyrhing.

so summed up:
2.1.2 - everything displayed, 2.1.3 and later- partially invisible.
VDM, AviSynth, VobSub: no problems with the subs.

P.S.: I attached a sub with these prblems.

Attachments (1)

Naruto Shippuuden 086 Untertitel Intro.ass (38.9 KB) - added by anime-neechan 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by anime-neechan

comment:1 Changed 4 years ago by TheFluff

I have no idea what you're trying to do or how you're doing it but here's a few pointers:
1) don't use vobsub 2.23 for anything ever (copy vsfilter.dll from your aegisub/csri folder to the vdub plugin folder and rename it to vsfilter.vdf instead)
2) it's not legal ass to have spaces in override tag blocks ( the {}'s)
3) I have no idea where you got the [Template] section from but it's not from Aegisub, and I have nfc what aegisub or vsfilter makes of it

comment:2 Changed 4 years ago by nielsm

The file works for me, despite the weirdnesses already mentioned.
Also check your script resolution, it's that mad default 384x288 which is most likely not what you want.

What I did:

  1. Open attached file in Aegisub 2.1.8 on Windows
  2. Say No to load associated files
  3. Open Dummy Video, 1280x720 at 23.976 fps
  4. Right-click the video seek bar to put focus to it
  5. Hold down the right arrow button on the keyboard to go through the video

I then see all the subtitles.

comment:3 Changed 4 years ago by anime-neechan

thx, it really was only the 1 space between the 2 \t-Tags. All the other spaces didn't matter. I hope you'll correct that, because that's such a pointless error.
and by the way, in the new 2.1.8 version the subs seem a little blurry although the video is at 100% and there are no blur-tags in them.
oh, and the manual is connected to the aegisub main page:
http://aegisub.cellosoft.com/docs/Karaoke_Templater_Tutorial_1
ant there are also free spaces between the \t-Tags.
But thx again.

comment:4 Changed 4 years ago by nielsm

  • Milestone temp deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing since this seems to not be an issue after all.

As for blurry video, it's a known bug and I believe we already have fixed it for the next version. You can work around it by selecting Video -> Override Aspect Ratio -> Custom, and enter the video resolution plus 4 pixel in each direction. For example, if your video is 640x480, you enter "644x484".

I don't see any spaces in the tutorial however, though it might look like it due to the monospaced font.

Note: See TracTickets for help on using tickets.